WordPress에서 자동 업데이트 실패? FTP 실패?

워드프레스(WordPress)최근에 WordPress와 함께 사용하기 위해 자체 서버를 구성한 클라이언트가 있습니다. 최근 3.04 보안 업데이트를 통해 모든 클라이언트에이 버전을 설치해야하는 시급함이있었습니다. 그러나이 특정 클라이언트는 항상 WordPress를 수동으로 업그레이드해야합니다.

우리는 전형적인 "파일을 쓸 수 없습니다”오류가 있습니다. 대신 FTP 로그인 화면이 제공되었습니다. 문제는 우리가 FTP 자격 증명을 입력하고 여전히 실패… 이번에는 좋은 자격 증명을 기반으로합니다!

인디애나 주 라이프 라인 데이터 센터에서 친구들과 연락을 취했습니다. 가장 큰 데이터 센터, 일부 Apache 괴짜가 있고 자체 서버를 구성했기 때문입니다. 그들은 저에게 간단한 솔루션을 제공했습니다. – FTP 자격 증명을 WP-config.php를 FTP 자격 증명을 하드 코딩하는 파일 :

define ( 'FTP_HOST', 'localhost'); define ( 'FTP_USER', '사용자 이름'); define ( 'FTP_PASS', '비밀번호');

어떤 이유로 양식에서 작동하지 않는 동일한 자격 증명은 구성 파일에 넣을 때 완벽하게 작동했습니다! 뿐만 아니라, WordPress가 FTP 없이도 작동하도록합니다. 업데이트를 클릭하고 이동하십시오!

댓글 4

  1. 1

    서버를 재 구축하고 새 WordPress 설치를 실행 한 후 WordPress 자동 업데이트 오류가 발생했습니다. 내 문제는 WordPress가 아닌 Firefox에서 발생했습니다. 다른 사람들은 FTP 사용자 이름과 WordPress 사용자 이름이 내 것과 같을 경우 동일한 문제를 경험할 수 있습니다 (대소 문자와 암호는 다르지만).

    문제는 "암호 기억"을 활성화 한 경우 Firefox가 양식의 사용자 / 암호를 암호 관리자에 저장된 내용을 기반으로해야한다고 생각하는 형식으로 자동 수정한다는 것입니다. 제 경우에는 WordPress 자격 증명이 저장되었지만 FTP 자격 증명은 사이트에 SSH하는 데 사용할 수 있기 때문에 저장되지 않았습니다. 이 상황에 처한 사람들은 WordPress 자동 업데이트를 사용하려고 할 때 기본 설정 / 옵션에서 "암호 기억"을 일시적으로 비활성화하거나이 동작을 수정하기 위해 WordPress에 코드를 적용 할 수 있습니다.

  2. 2

    더그,

    Apache의 홈 빌드에서도 동일한 문제가 발생했습니다. 특정 파일 및 디렉토리에 대한 부적절한 권한 및 소유권의 결과로 밝혀졌습니다.

    http://robspencer.net/auto-update-wordpress-without-ftp/

    위의 링크는 ftp 자격 증명을 사용하지 않고 문제를 해결하는 방법에 대한 통찰력을 제공했습니다. 물론 전체 사용자 디렉토리를 775로 자르는 것은 권장하지 않지만 (나는 그렇게하지 않았습니다) 올바른 방향으로 인도합니다.

    아담

  3. 3

    가능한 해결책을 찾는 다른 사람들을 위해 : 또 다른 블로거는 그의 호스트가 .httaccess 파일에 다음을 추가하여 php5를 사용하도록 강요함으로써 자동 업데이트 문제를 해결했습니다.

    AddType x-mapp-php5 .php

  4. 4

    지식을 공유해 주셔서 감사합니다. 자동 업데이트에 문제가 있었지만 내가 찾은 유일한 해결책은 플러그인을 비활성화 한 다음 WordPress를 자동 업데이트하고 마지막으로 모든 플러그인을 반응시키는 것입니다.

    이 팁은 다른 문제에 대한 것이지만 해결 방법을 아는 것이 좋습니다.

    멕시코에서 인사드립니다!

당신은 어떻게 생각하십니까?

이 사이트는 Akismet을 사용하여 스팸을 줄입니다. 댓글 데이터 처리 방법 알아보기.